Adding the Audience Network SDK to your Android App

Android

For information on meeting the new requirements for Android 9 and later, see Android Network Security Config.

Maven (Preferred Download Method)

Add this to Module-level /app/build.gradle before dependencies:

repositories {
    // Ensure that you have mavenCentral() in list of repositories.
    mavenCentral() 
}

Add the implementation dependency with the latest version of the Facebook SDK in the build.gradle file:

dependencies { 
    implementation 'com.android.support:support-annotations:28.0.0' // Required Dependency by Audience Network SDK
    implementation 'com.facebook.android:audience-network-sdk:5.+'
}

Manual Download

Learn More