Partial Outageshare-external
Unsupported post request. Object with ID act_xxxxxxxxx does not exist
3

Making calls to the marketing API as I've been doing suddently stopped to work. There is any known issue?

Details here:

  Status:  400
  Response:
    {
      "error": {
        "message": "Unsupported post request. Object with ID 'act_xxxxxxxxxx' does not exist, cannot be loaded due to missing permissions, or does not support this operation. Please read the Graph API documentation at https://developers.facebook.com/docs/graph-api",
        "type": "GraphMethodException",
        "code": 100,
        "error_subcode": 33,
        "fbtrace_id": "HihUXD8a35/"
      }
    }

Thanks!

Alejandro
Asked about 3 years ago
Selected Answer
1

I am with the same problem trying to do a get:

public function testIII(){
        $api = Api::init($this->_app_id, $this->_app_secret, $this->_access_token);
        $api->setLogger(new CurlLogger());
        $account = new AdAccount($this->_ad_account_id);

        $params = array(
        'level' => AdsInsightsLevelValues::AD,
        'filtering' => array(
            array(
            'field' => 'adgroup.adlabels',
            'operator' => InsightsOperators::ANY,
            'value' => array('<AD_LABEL_NAME>'),
            ),
        ),
        'time_range' => array(
            'since' => '2015-03-01',
            'until' => '2015-03-31',
        ),
        );

        $fields = array(
        AdsInsightsFields::INLINE_LINK_CLICKS,
        AdsInsightsFields::COST_PER_INLINE_LINK_CLICK,
        AdsInsightsFields::TOTAL_ACTIONS,
        );

        $stats = $account->getInsights($fields, $params);
}    
February 4 at 1:35 PM
Davi
2

We have the same problem - a bunch of accounts that used to exist seem to not longer have permissions and are not being returned in me/adaccounts anymore. They were prior to 3.2

May 29 at 5:56 AM
Colin
2

Does anyone get a solution for this issue? I am facing the same issue on v3.2

August 14 at 12:45 AM
Mk
4

Did you double check what the error response suggests? Does the token you use incl all required permissions to access this account ID?

May 29 at 5:55 AM
Lars
4

I was also having same issue, i solved it. Solution is simple, to get the correct Ad Account ID Visit the following link. with your valid access token. https://graph.facebook.com/v5.0/me/adaccounts?access_token=VALIDACCESSTOKEN

Hope it was helpful.

February 6 at 3:19 AM
Muhammad Ali
Davi

Perfect sir! Solved my problem!

February 6 at 8:23 AM
Shambhavi

Worked!

September 30 at 6:18 AM
Josías

In my case I need to configure correctly permission to apps on business settings

October 23 at 3:37 PM
Karan

how ? can anybody tell me ? how i get my solution using this link

March 4 at 10:19 PM
Akshay

i m getting same error plz help ...your solution is not working anymore

March 8 at 10:12 PM
Muhammad Ali

for people still getting this error, you will need to Configure the permissions correctly.

March 9 at 3:41 AM