News for Developers

Back to News

Introducing Marketing API, v3.2

On October 23, 2018, 10:30 am PT, we're releasing Marketing API, version 3.2, and introducing a new ads run status WITH_ISSUES, which indicates if there is something wrong with your ad and Facebook can't deliver it. Together with this new run status, we introduce ISSUES_INFO, which provides more detail with the error_code that prevented your ad from delivering.

Below is a highlight of updates. To learn more about new features, updates, deprecations, and impacts, see the Marketing API v3.2 changelog.

Ads Management

  • You can now only create a Dynamic Creative ad groups only under a Dynamic Creative ad campaign by specifying is_dynamic_creative.

  • Deprecated asset_feed_id from GET and POST used in Dynamic Creative.

Instead of using these APIs, use asset_feed_spec in ad creative to specify all the assets, such as images and text, to use in your Dynamic Creative ads. See Dynamic Creative.

  • Deprecated language asset feeds used to optimize different languages which display in your ad's creative. See Optimize Languages.

Instead, use asset_feed_spec to specify different languages. For more information, see Optimize Languages.

  • Changed the API for language asset feeds to use asset customization rules instead of group rules. This provides you a more unified way to create and optimize languages that display in unique ad creative per impression.

Dynamic Ads

Product sets now must contain at least one product for use in Dynamic Ads, product catalogs. From now on, if you try to create a set with no products, we return an error. This impacts product_catalog_ID/product-set.

Ads Insights and Measurement

Deprecated several ads-related metrics under Insights API to simplify reporting and support reporting based on our new eight standard events.

Business Manager API

Deprecated /userpermissions. Instead, use business_users, system_users, or pending_users. See Business Manager API, Managing People, and Roles.

Upgrading to Marketing API v3.2

A few key reminders for our developer community:

  • All versions prior to Marketing API v3.0 will be deprecated at October 23, 2018.
  • All apps need to be on at least v3.2.
  • Developers should specify /v3.2/ in your URLs when you call the API.
  • To see details of changes in v3.2, see the Graph API v3.2 Changelog.
  • SDK developers should view our latest Java SDK, PHP SDK, Python SDK, or Ruby SDK.

Related News

April 30 2019

December 18 2018

July 17 2018

February 28 2018